Задать вопрос
20 мая, 05:03

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран.

+2
Ответы (1)
  1. 20 мая, 09:01
    0
    var a:array [1 ... 10] of integer;

    b, i:integer;

    z:real;

    begin

    randomize;

    for i:=1 to 10 do

    begin

    z:=random;

    b:=random (10) ;

    if z>0.5 then a[i]:=b

    else a[i]:=-b;

    end;

    for i:=1 to 10 do

    write (' ', a[i]) ;

    end.

    если что то не понятно, спрашивай)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)