Задать вопрос
15 февраля, 18:30

вводится последовательность чисел, 0 - конец последовательности. вычислить сумму чисел после первого отрицательного

+1
Ответы (1)
  1. 15 февраля, 21:27
    0
    Если на паскале

    program dds;

    const n=10;

    var a:array[1 ... n]of integer;

    i, o, s, z:integer;

    begin randomize; s:=0; z:=0; a[n]:=0;

    a[n]:=0; for i:=1 to n-1 do a[i]:=random (10) - 5;

    for i:=1 to n do if (a[i]<0) and (z=0)

    then begin z:=1; for o:=i+1 to n do

    s:=s+a[o]; end

    ; for i:=1 to n do write (a[i]:4) ; writeln;

    write ('symma=', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «вводится последовательность чисел, 0 - конец последовательности. вычислить сумму чисел после первого отрицательного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Вводится последовательность целых ненулевых чисел, 0 - конец последовательности. Определить, сколько раз последовательность поменяет знак. Ограничения! Нельзя использовать условный оператор (If) и оператор выбора (Case).
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
1. Вводится не менее восьми чисел. Конец ввода 0. Найти сумму первых пяти чисел и произведение последних пяти чисел. Составить блок-схему и программу к задаче. 2. Вводится текст. Конец ввода F4. Найти количество букв.
Ответы (1)