Задать вопрос
25 января, 16:02

Дано семизначное число. Определить, является ли оно симметричным.

+1
Ответы (1)
  1. 25 января, 17:16
    0
    Program n1;

    Var c, i: integer;

    a: array[0 ... 6] of integer;

    begin

    Writeln ('Vvedite chislo') ;

    Readln (c) ;

    For i:=6 downto 0 do

    begin

    a[i]:=c mod 10;

    c:=c div 10;

    write (a[i]:3) ;

    end;

    If (a[0]=a[6]) and (a[1]=a[5]) and (a[2]=a[4]) then writeln ('Simmetrichnoe')

    else writeln ('Nesimmetrichnoe') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано семизначное число. Определить, является ли оно симметричным. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1 задача) на Paskal В условии одной из задач на этом сайте написано: "Если данное четырехзначное число является симметричным, выведите 1, иначе выведите любое другое целое число".
Ответы (1)
Определите, является ли не более чем четырехзначное число k симметричным (например, 1331 или 0550). На вход программе подается целое число k (0 k 9999).
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)