Задать вопрос
4 февраля, 22:39

Написать программу, которая в заданном одномерном массиве размерности N меняет местами соседние элементы, стоящие на чётных местах, с соседними элементами, стоящими на нечётных местах.

+4
Ответы (1)
  1. 4 февраля, 23:30
    0
    var a:array[1 ... 10] of integer;

    i, tmp:integer;

    begin cls;

    for i:=1 to 10 do a[i]:=i;

    for i:=1 to 10 do

    begin

    if i mod 2 = 1 then

    begin

    tmp:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=tmp;

    end;

    end;

    for i:=1 to 10 do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая в заданном одномерном массиве размерности N меняет местами соседние элементы, стоящие на чётных местах, с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заполнить массив случайными числами в интервале[ - 100; 100] и поменять местами соединение элементы, стоящие на четных местах, с элементами, стоящими на нечетных местах. Вычислить кол-во четных элементов. Гномья сортировка.
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
Задать массив m (7) случайными числами от 12 до 73. Утроить элементы массива, стоящие на нечетных местах. Утроить чётные элементы массива, стоящие на нечетных местах
Ответы (2)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив А (20). Переписать элементы этого массива, стоящие на четных местах, подряд в массив В, а стоящие на нечетных местах - в массив С. Все три массива отпечатать. (сложнА, знаю) хыхыхы
Ответы (1)