Задать вопрос
7 февраля, 17:32

Составить программу (Паскаль) построения на экране n прямоугольников разного цвета, расположенных хаотично.

+4
Ответы (1)
  1. 7 февраля, 20:32
    0
    uses graph;

    var n, i, x, y, height, width:integer;

    procedure init;

    var gd, gm:integer;

    begin

    gd:=vga;

    gm:=vgahi;

    initgraph (gd, gm,'') ;

    end;

    procedure error;

    begin

    closegraph;

    writeln ('error!') ;

    end;

    begin

    write ('N = ') ;

    readln (n) ;

    randomize;

    init;

    if graphresult = 0 then

    begin

    for i:=1 to n do

    begin

    setcolor (random (14) + 1) ;

    x:=random (640) ;

    y:=random (480) ;

    height:=random (91) + 10;

    width:=random (101) + 20;

    rectangle (x, y, x+width, y+height) ;

    end;

    end else error;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу (Паскаль) построения на экране n прямоугольников разного цвета, расположенных хаотично. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
1) Проанализируй и напиши программу на языке Паскаль. Вычислить n!, если значение n пользователь вводит с клавиатуры. Если n=1, то на экране выводится n!= 2) Запиши программу на языке Паскаль.
Ответы (1)
Отметьте то что является экранным 1 кнопка включения монитора 2 кнопка на экране монитора 3 флажок на экране монитора 4 фирменный значок на лицевой панели монитора 5 пиктограмма документа на экране монитора
Ответы (1)