Задать вопрос
27 марта, 06:27

найти сумму двузначных положительных чисел сумма цифр которых кратно 7. (паскаль)

+1
Ответы (1)
  1. 27 марта, 10:15
    0
    Program Summa;

    var

    n,

    l,

    a: integer;

    m: integer;

    b: integer;

    k: integer;

    begin

    Readln (n) ;

    Readln (l) ;

    a:=n div 10;

    m:=l div 10;

    b:=n mod 10;

    k:=l mod 10;

    if (a+b) mod 7=0 then write (n,' ') ;

    if (m+k) mod 7=0 then write (n+l) ;

    End.

    Попробуй
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти сумму двузначных положительных чисел сумма цифр которых кратно 7. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)