Задать вопрос
23 апреля, 01:07

програмку в паскаль напишите кто знает плииз**

составить программу калькулятор который после ввода 2 чисел и одного из знаков плюс или минус произведет вычисление а результат выдаст на экран

+3
Ответы (1)
  1. 23 апреля, 02:54
    0
    Так?

    Program P1;

    Var a, b : Integer;

    s : Char;

    Begin

    Write ('Введи 1 число: ') ;

    Readln (a) ;

    Write ('Введи знак (+ или -) : ') ;

    Readln (s) ;

    Write ('Введи 2 число: ') ;

    Readln (b) ;

    Case s of

    '-': Write (a, ' - ', b, ' = ', a - b) ;

    '+': Write (a, ' + ', b, ' = ', a + b) ;

    Else

    Write ('Неверный символ!') ;

    End;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «програмку в паскаль напишите кто знает плииз** составить программу калькулятор который после ввода 2 чисел и одного из знаков плюс или ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)