Задать вопрос
24 июня, 20:59

составить программу на языке Паскаль числа по возрастанию.

+2
Ответы (1)
  1. 24 июня, 23:37
    0
    program parampampam;

    uses crt;

    var

    i: integer; {счетчик}

    s: integer;

    begin

    clrscr; {очистка экрана}

    writeln ('Программа выводит числа от 1 до 99, сумма цифр которых равна числу S') ;

    writeln ('Введите число S, от 0 до 18: ') ;

    {ввод числа S с проверкой на корректность}

    repeat

    readln (s) ;

    if (s>18) or (s<0) then

    writeln ('Неверный ввод. Повторите')

    until (s=0) ;

    {вывод нужных чисел на экран (цикл с предусловием) }

    for i : = 1 to 99 do

    if ((i div 10) + (i mod 10) = s) then {div дает целую часть, mod - остаток от деления}

    write (i, ' ') ;

    repeat until keypressed; {пустой цикл для задержки экрана до нажатия клавиши}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу на языке Паскаль числа по возрастанию. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)