Задать вопрос
25 апреля, 00:04

Составить программу для Pascal ABC, печатающую значение true, если указанное высказывание является истинным, и false в противном случае, когда данная тройка натуральных чисел a, b, c является тройкой Пифагора, т. е. c^2 = a^2 + b^2.

+5
Ответы (1)
  1. 25 апреля, 02:07
    0
    uses crt;

    var

    t1:boolean;

    a, b, c: integer;

    begin

    readln (a, b, c) ;

    if c*c=a*a+b*b then t1: = true else t1: = false;

    writeln (t1) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для Pascal ABC, печатающую значение true, если указанное высказывание является истинным, и false в противном случае, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае, когда хотя бы одно из чисел x, y, z больше 100.
Ответы (1)
Составить программу печатающую значение true если указанное высказывание является истинным и false в противном случае треугольник со сторонами а в с является равнобедренным
Ответы (1)
Составить программу печатающую зн ачение true если указанное высказывание является истинным, и false - в противном случае натуральное число N является точным квадратом
Ответы (1)
составьте программу печатающую значение true если указанное высказывание является истинным и false в противном случае сумма цифр данного трехзначного числа N является четным числом
Ответы (1)