Задать вопрос
24 марта, 18:48

Нужно сделать в паскаль АВС

Самолет летит из пункта А в пункт Б со средней скоростью V. Составить программу для нахождения времени полёта t1, если есть встречный ветер, скорость которого V1, и времени t2, если ветра нет. Расстояние между пунктами A и Б считать известным и равным S.

+2
Ответы (1)
  1. 24 марта, 20:31
    0
    var S, V, V1: real;

    t1, t2: real;

    b: boolean;

    begin

    b:=false;

    repeat

    writeln ('Введите расстояние между пунктами А и Б') ;

    readln (S) ;

    if S<0 then

    begin

    writeln ('Отрицательное расстояние. Повторите ввод') ;

    continue;

    end;

    writeln ('Введите среднюю скорость самолета') ;

    readln (V) ;

    if V<0 then

    begin

    writeln ('Отрицательная скорость. Повторите ввод') ;

    continue;

    end;

    writeln ('Введите скорость встречного ветра') ;

    readln (V1) ; / / Если ветра нет нужно ввести 0

    if V1<0 then

    begin

    writeln ('Отрицательная скорость. Повторите ввод') ;

    continue;

    end;

    b:=true;

    until b = true;

    if V1>0

    then

    begin

    t2:=S/V;

    writeln ('Время полета: ', t2) ;

    end

    else

    begin

    t1: = (V-V1) / S;

    writeln ('Время полета: ', t1) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно сделать в паскаль АВС Самолет летит из пункта А в пункт Б со средней скоростью V. Составить программу для нахождения времени полёта ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Файл размером 2000 Кбайт из пункта A в пункт Б передаётся за 30 секунд, а из пункта Б в пункт В передаётся за 20 секунд.
Ответы (1)
1. Переведите известным вам способом число 12 в двоичную систему счисления. 2. Переведите известным вам способом число 0,375. в двоичную систему счисления 3. Переведите известным вам способом число 12,375 в двоичную систему счисления.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Данные объемом 80 Мбайт передаются из пункта А в пункт Б по каналу связи, обеспечивающему скорость передачи данных 2∧23 бит в секунду, а затем из пункта Б в пункт В по каналу связи, обеспечивающему скорость передачи данных 2∧20 бит в секунду.
Ответы (1)