Задать вопрос
31 января, 00:23

Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат.

+2
Ответы (2)
  1. 31 января, 02:16
    0
    program z1;

    uses crt;

    var x, y:integer;

    begin

    clrscr;

    writeln ('введи число') ;

    readln (x) ;

    if x>=0 then x:=x*2

    else

    if x<0 then sqr (x) ;

    writeln (x) ;

    readln;

    end.
  2. 31 января, 03:31
    0
    Pascal ABC

    var a : integer;

    begin

    readln (a) ;

    If a > = 0 then a : = 2*a;

    If a < 0 then a : = a*a;

    writeln (a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
составьте программу которая возводит в квадрат введенное целое число если оно отрицательное и выводит на экран результат
Ответы (1)