Задать вопрос
26 октября, 05:18

Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов.

+4
Ответы (1)
  1. 26 октября, 06:18
    0
    program jfe3;

    const n=10; {Это будет кол-во элементов массива}

    var a:array [1 ... n] of integer; i, s:integer;

    begin

    for i:=1 to n do begin

    a[i]:=random (100) ; {элемент выбирается случайно от 0 до 100}

    s:=s+a[i]; {Когда эл. присвоился, его значение плюсуется к общ сумме}

    end;

    for i:=1 to n do

    writeln (a[i],' ') ; {показать сам массив}

    writeln (s) ; {показать сумму}

    readln; {чтобы окно сразу не закрывалось}

    end.

    Если есть вопросы по программе, пиши в личку. Если надо что-то еще - тоже =)

    Удачи)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)