Задать вопрос
1 июля, 02:55

дано двузначное число. определить больше ли числа A сумма его цифр.

+3
Ответы (1)
  1. 1 июля, 06:39
    0
    Pascal:

    var n, a, s:longint;

    begin

    repeat

    write ('N = ') ;

    readln (n) ;

    until n in [10 ... 99];

    write ('A = ') ;

    readln (a) ;

    s:=0;

    while n0 do

    begin

    s:=s+n mod 10;

    n:=n div 10;

    end;

    if s>a then writeln ('YES') else writeln ('NO') ;

    readln;

    end.

    C++:

    #include

    using namespace std;

    int main ()

    {

    int a, n, s = 0;

    do

    {

    cout <<"N = ";

    cin >>n;

    }

    while (n99) ;

    cout <<"A = ";

    cin >>a;

    while (n!=0)

    {

    s+=n%10;

    n/=10;

    }

    if (s>a)

    cout <<"YES" <
    else cout <<"NO" <
    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано двузначное число. определить больше ли числа A сумма его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Дано двузначное число. Определить: а) является ли сумма его цифр двузначным числом; б) больше ли числа а сумма его цифр.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)