Задать вопрос
25 мая, 04:56

с клавиатуры вводятся числа пока их сумма меньше 300. Найти произведение отрицательных чисел делящихся на 3

+3
Ответы (1)
  1. 25 мая, 08:36
    0
    var x, s, p:integer;

    begin

    p:=1;

    while s<300 do begin

    readln (x) ;

    if x mod 3=0 then p:=p*x;

    s:=s+x;

    end;

    if p1 then writeln (p) else writeln ('0') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «с клавиатуры вводятся числа пока их сумма меньше 300. Найти произведение отрицательных чисел делящихся на 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
с клавиатуры вводятся 11 чисел найти произведение отрицательных чисел делящихся на 17.
Ответы (2)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)