Задать вопрос
9 декабря, 23:02

Составить программу на Паскале сортировки массива по возрастанию

+3
Ответы (1)
  1. 10 декабря, 02:46
    0
    Сортировка методом пузырька:

    const n=10;

    Var a:array[1 ... n] of integer; i, j, b:integer;

    Begin

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if a[j]
    begin

    b:=a[i];

    a[i]:=a[j];

    a[j]:=b;

    end;

    for i:=1 to n do write (a[i],' ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на Паскале сортировки массива по возрастанию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Помогите вопросы по информатике. 1. Какой вид сортировки используют для сортировки по нескольким параметрам? 2. Назначение сортировки 3. Какие типы данных можно сортировать.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)