Задать вопрос
10 августа, 00:18

составить программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и находит минимальный элемент массива и его индекс

+5
Ответы (1)
  1. 10 августа, 02:15
    0
    var

    a: array [1 ... 10] of integer;

    i, min, MinIndex: integer; {min - значение минимального элемента массива, MinIndex - индекс минимального элемента массива}

    begin

    min: = 20;

    write ('Исходный массив: ') ;

    for i: = 1 to 10 do

    begin

    a[i]: = random (19) + 1;

    write (a[i], ' ') ;

    if a[i] < min then

    begin

    min: = a[i];

    MinIndex: = i;

    end;

    end;

    writeln;

    write ('Минимальный элемент массива: a[', MinIndex, '] = ', min) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и находит минимальный элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)