Задать вопрос
20 июля, 09:01

найти произведение чисел N, которые делятся на 3 нацело.

+5
Ответы (1)
  1. 20 июля, 09:55
    0
    Если N это количество чисел, начинаем с 3

    var

    i, n, p:integer

    begin

    readln (n) ;

    i:=3;

    p:=1;

    while i<=3*n do

    begin

    p:=p*i;

    i:=i+3;

    end;

    writeln (p) ;

    end.

    Если N это верхняя граница чисел

    var

    i, n, p:integer

    begin

    readln (n) ;

    for i:=3 to n

    if i mod 3 = 0 then

    p:=p*i;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти произведение чисел N, которые делятся на 3 нацело. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Найти все трёхзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
Ответы (1)
Даны 2 целых числа m и n. Напишите программу которая выводит на экран частное от деления m на n, если они делятся нацело, а в противном случае сообщение m на n нацело не делится.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)