Задать вопрос
15 декабря, 04:52

Вычислить произведение 2-ух натуральных чисел используя лишь операцию сложения

В паскале

+2
Ответы (1)
  1. 15 декабря, 08:15
    0
    Я, в основном, программы на С + + пишу, но из школы про Паскаль кое-что помню (в смысле, попытаюсь написать на Паскале).

    Program A1;

    var a, b, c, i:integer;

    begin

    write ('Enter the a: ') ;

    read (a) ;

    writeln ('Enter the b: ') ;

    read (b) ;

    с:=0;

    for i:=1 to a Do

    c:=c+b;

    writeln ('a*b=', c:5:0) ;

    end.

    Объясняю (начинаю сразу с цикла for) : что значит произведение двух натуральных чисел а и b - это означает, сложить b с самим собой по а раз (можно и наоборот). Например, a=5, b=3. Переменную с=0 будем складывать с b.

    i=1 c=5+0;

    i=2 c=5+5;

    i=3 c=10+5; / / c=15

    Вот и есть ответ: 5*3=15.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить произведение 2-ух натуральных чисел используя лишь операцию сложения В паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Создайте программы на языке PascalABC: 1) Введите два числа (например A=5 и В=8) и найдите их произведение, используя цикл с постусловием и только операцию сложения.
Ответы (1)
Дано 2 числа а и б найти произведение а на используя лишь операцию сложения
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Выполнить операцию сложения над двоичными числами: а) 101010+1101 б) 1010+1010 в) 10101+111 Выполнить операцию умножения над двоичными числами: а) 1010*11 б) 111*101 в) 1010*111
Ответы (1)
Как выполнить данную операцию на паскале? вычислить (1 + (1 / (1^2))) * (1 + (1 / (2^2))) * (1 + (1 / (3^2))) ... * (1 + (1 / (n^2))) если кому легче то вот как оно же выглядит на паскале (1 + (1 / (1*1))) * (1 + (1 / (2*2))) * (1 + (1 / (3*3))) ...
Ответы (1)