Задать вопрос
31 мая, 19:14

1. Для данного массива установить наибольшую длину последовательности одинаковых элементов, которые расположены рядом.

+4
Ответы (1)
  1. 31 мая, 19:45
    0
    uses crt;

    var a:array[1 ... 11] of integer;

    i, j, s, k:integer;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to 10 do begin

    a[i]:=random (5) ;

    write (a[i]:4) ;

    end;

    s:=1; k:=0;

    for i:=1 to 10 do begin

    if a[i]=a[i+1] then s:=s+1;

    if a[i]a[i+1] then begin if k
    end;

    writeln;

    writeln ('Наибольшая последовательность одинаковых элементов: ', k) ; write (k) ;

    end.

    Массив состоит из 10 чисел (в описании максимум чисел должен быть на 1 больше, чем по факту, поэтому там 11). Числа в массиве задаются случайно в пределах от нуля до 5 (не включая 5).
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Для данного массива установить наибольшую длину последовательности одинаковых элементов, которые расположены рядом. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)