Задать вопрос
28 октября, 15:54

Написать программу, которая в массиве случйных чисел С[1 ... 5,1 ... 5] меняет местами значения элементов главной и вспомогательнй диагонали

+2
Ответы (2)
  1. 28 октября, 17:33
    0
    uses crt;

    var C:array[1 ... 5,1 ... 5] of integer;

    i, j, temp:integer;

    begin

    randomize () ;

    for i:=1 to 5 do

    for j:=1 to 5 do

    C[i, j]:=random (1000) ;

    for i:=1 to 5 do begin

    t:=C[i, i];

    C[i, i]:=C[i, 6-i];

    C[i, 6-i]:=t;

    end

    end.
  2. 28 октября, 18:43
    0
    program pr;

    uses crt;

    Var i, j, b:integer;

    C:array[1 ... 5, 1 ... 5] of integer;

    Begin

    for i:=1 to 5 do Begin

    Writeln;

    for j:=1 to 5 do Begin C[i, j]:=random (100) ; Write (C[i, j],'|') ; end;

    end;

    for i:=1 to 5 do

    Begin

    b:=C[i, i];

    C[i, i]:=C[i, 6-i];

    C[i, 6-i]:=b;

    end;

    Writeln;

    for i:=1 to 5 do Begin

    Writeln;

    for j:=1 to 5 do Write (C[i, j],'|') ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая в массиве случйных чисел С[1 ... 5,1 ... 5] меняет местами значения элементов главной и вспомогательнй диагонали ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)