Задать вопрос
12 июля, 02:58

Составьте программу вычисления в массиве A (N) произведения четных элементов.

+2
Ответы (2)
  1. 12 июля, 06:05
    0
    program csdnciuo;

    uses crt;

    'var a:array [1 ... 100] of integer;

    i, p, n:integer;

    begin

    clrscr;

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ;

    p:=1;

    for i:=1 to n do

    if a[i] mod 2 = 0 then p:=p*a[i];

    writeln (p) ;

    readln;

    end.
  2. 12 июля, 06:10
    0
    var

    a: array [1 ... 100] of integer;

    i, p, n: integer;

    begin

    p : = 1;

    read (n) ;

    for i : = 1 to n do

    begin

    read (a[i]) ;

    if a[i] mod 2 = 0 then

    p : = p * a[i];

    end;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления в массиве A (N) произведения четных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal 2) составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)