Задать вопрос
11 сентября, 16:13

Дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а, если нет, то произведение

+3
Ответы (1)
  1. 11 сентября, 19:26
    0
    program zisla;

    uses crt;

    var a, b, c, d, s, g, n, v: real;

    begin

    cls;

    write ('введите 4 числа') ;

    read (a, b, c, d) ;

    s:=a+b+c+d;

    g:=s/100;

    if g=g/2 then

    begin

    v:=s/4;

    writeln ('среднее этих чисел=', s) ;

    end

    else

    begin

    n:=a*b*c*d;

    writeln ('произведение этих чисел', n)

    end;

    end.

    решал на паскале абс

    Ставь лучшее решение
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а, если нет, то произведение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
1) Задано 3 целых числа a, b, c. Узнать есть среди них хоть 1 четное. 2) Посчитать кол-во четных чисел.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
С клавиатуры вводится два трехзначных числа. Возвести первое число в квадрат, а из второго извлечь корень, если хотя бы у одного из чисел, средняя цифра четная. В противном случае из первого извлечь корень, а второе возвести в квадрат.
Ответы (2)