Задать вопрос
22 сентября, 13:49

Дана геометрическая прогрессия 3, 6, 12, 24, ...

Чему будет равна сумма 13-ти ее членов?

(составить программу в паскале+по возможности с блок-схемой)

+5
Ответы (1)
  1. 22 сентября, 15:08
    0
    var a:array [1 ... 13] of real;

    i: integer;

    q, s:real;

    begin

    s:=3;

    a[1]:=3;

    a[2]:=6;

    a[3]:=12;

    a[4]:=24;

    q:=a[2]/a[1];

    for i:=2 to 13 do

    begin

    a[i]:=a[i-1]*q;

    s:=s+a[i];

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана геометрическая прогрессия 3, 6, 12, 24, ... Чему будет равна сумма 13-ти ее членов? (составить программу в паскале+по возможности с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы