Задать вопрос
10 мая, 11:33

Напишите программу, которая выводит на экран числа в указанном виде. Пример для n=6:

1

1 2

1 2 3

1 2 3 4

1 2 3 4 5

1 2 3 4 5 6

почему не получается вот программа

program qq1;

var n, i, j:integer;

begin

writeln (' введите значение n:') ;

readln (n) ;

for i:=1 to n do begin

for j:=1 to i do write (j-i,'') ;

writeln () ;

end;

end.

+4
Ответы (1)
  1. 10 мая, 13:27
    0
    program qq1;

    var n, i, j:integer;

    begin

    writeln (' введите значение n:'') ;

    readln (n) ;

    for i:=1 to n do begin

    for j:=1 to i do write (j,' ') ; / / тут заменил j - i на j и в ковычках добавл пробел

    writeln () ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит на экран числа в указанном виде. Пример для n=6: 1 1 2 1 2 3 1 2 3 4 1 2 3 4 5 1 2 3 4 5 6 почему не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Почему программа не работает (Pascal) Program abc; Var A, B: array [1 ... 5] of integer; i:integer; begin For i : = 1 to 5 do begin writeln ('введите A') ; readln (A[i]) ; writeln ('Введите B') ; readln (B[i]) ; writeln (A[1]+B[1]) ;
Ответы (1)
Написать программу нахождения периметра параллелограмма по известным сторонам b и h (b и h - целые числа, вводимые с клавиатуры).
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m') ; readln (c, m) ; s:=c*m; writeln ('s=', s) ; readln; end.
Ответы (1)
Program a2; var n, i, min, max, x:integer; begin Writeln ('Введите колицество человек в классе:') ; Readln (n) ; Writeln ('Введите рост 1 ученика:') ; readln (x) ; min:=x; max:=x; for i:=2 to n do begin Writeln ('Введите рост ', i,' ученика:') ;
Ответы (1)