Задать вопрос
14 сентября, 08:50

Написать алгоритм и программу квадратного уравнения

+1
Ответы (2)
  1. 14 сентября, 10:10
    0
    var

    a, kd, b, c, x2, x1, d:extended;

    begin

    read (a, b, c) ;

    d:=-4*a*c;

    if d>0 then

    begin

    kd:=sqrt (d) ;

    x1: = (-b+kd) / 2*a;

    x2: = (-b-kd) / 2*a;

    end;

    else

    write ('Нет корней') ;

    If x1=x2 then write (x1) else write (x1, x2) ;

    end.
  2. 14 сентября, 12:35
    0
    var

    a, kd, b, c, x2, x1, d:extended;

    begin

    read (a, b, c) ;

    d:=-4*a*c;

    if d>0 then

    begin

    kd:=sqrt (d) ;

    x1: = (-b+kd) / 2*a;

    x2: = (-b-kd) / 2*a;

    end;

    else

    write ('Нет корней') ;

    If x1=x2 then write (x1) else write (x1, x2) ;

    end
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать алгоритм и программу квадратного уравнения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
Соберите алгоритм содержащий план работы программиста над созданием программы (я здесь напишу в разброс и вы по порядку 1 ... 2 ... И Тд) Создать программу. получить задание. Отправить программу пользователю. Написать алгоритм. Отладить программу
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)
Алгоритм выполнения домашнего задания. Алгоритм рецепта приготовления пирога. Алгоритм мытья посуды. Алгоритм путешествия Колобка в известной сказке. Оформление.
Ответы (1)