Задать вопрос
2 апреля, 08:08

В полученной случайным образом последовательности N целых чисел из промежутка [10; 1000] найти числа, у которых ровно 4 делителя.

+4
Ответы (1)
  1. 2 апреля, 08:58
    0
    Const n=?; {Вместо "?" вставить значение}

    Var a:array[1 ... n] of integer;

    i:integer;

    Function del (x:integer) : integer; {Функция для определения кол-ва делителей}

    var i, k:integer;

    begin

    k:=0;

    for i:=1 to x do

    if (x mod i) = 0 then k:=k+1;

    del:=k;

    end;

    Begin

    randomize;

    for i:=1 to n do

    a[i]:=random[10,1000];

    for i:=1 to n do

    if del (a[i]) = 4 then write (a[i],' ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В полученной случайным образом последовательности N целых чисел из промежутка [10; 1000] найти числа, у которых ровно 4 делителя. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Выполнить алгоритм: 1) Найти сумму чисел 1 и 3; 2) Прибавить к полученной сумме число 5; 3) Прибавить к полученной сумме число 7; 4) Прибавить к полученной сумме число 9; 5) Прибавить к полученной сумме число 11; 6) Сообщить результат.
Ответы (2)
Выполните алгоритм 1) Найти сумму чисел 1 и 3. 2) Прибавить к полученной сумме число 5. 3) Прибавить к полученной сумме число 7. 4) Прибавить к полученной сумме число 9. 5) Прибавить к полученной сумме число 11. 6) Напечатай результат.
Ответы (2)
Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-100; 100] найти сумму положительных элементов, значения которых меньше 10. Pascal
Ответы (1)
Дан массив целых чисел (n=15), заполненный случайным образом числами из промежутка [-20,50]. - удалить из него все элементы, в которых есть цифра 5. - вставить число k после всех элементов, кратных своему номеру (k вводить с клавиатуры).
Ответы (1)