Задать вопрос
29 января, 05:13

Написать программу Вывод минимального элемента массива целых чисел

+2
Ответы (2)
  1. 29 января, 08:09
    0
    const

    n=15;

    var

    a:array [1 ... n] of integer;

    i, min:integer;

    begin

    for i:=1 to n do

    begin

    write ('A[', i,'] = ') ; readln (a[i]) ;

    end;

    min:=a[1];

    for i:=2 to n do

    if a[i]
    writeln ('Min: ', min) ;

    readln;

    end.
  2. 29 января, 08:35
    0
    uses crt;

    var

    a:array[1 ... 100] of integer;

    i, min:integer;

    begin

    randomize;

    write ('Введи количество элементов массива: ') ; read (i) ;

    min:=100;

    clrscr;

    writeln ('Массив: ') ;

    for i:=1 to i do

    begin

    a[i]:=random (10) - 9;

    write (a[i]:4) ;

    if a[i]
    end;

    writeln;

    write ('Минимальный элемент массива: ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу Вывод минимального элемента массива целых чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм R: = n; For k: = 1 to n do If X[k]
Ответы (1)