Задать вопрос
25 ноября, 03:24

По времени определить время суток. Оператор выбора case.

+2
Ответы (1)
  1. 25 ноября, 05:38
    0
    uses crt;

    var

    n, k:integer;

    begin

    write ('Введите час') ;

    read (n) ;

    if n>=24 then begin k:=n mod 24;

    n:=k; end;

    case n of

    6 ... 11:write ('Утро') ;

    13 ... 16:write ('День') ;

    17 ... 23:write ('Вечер') ;

    0 ... 5:write ('Ночь') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По времени определить время суток. Оператор выбора case. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
Вводится последовательность целых ненулевых чисел, 0 - конец последовательности. Определить, сколько раз последовательность поменяет знак. Ограничения! Нельзя использовать условный оператор (If) и оператор выбора (Case).
Ответы (1)
Для задержки результатов выполнения программы на экране: А) Используют пустой оператор вывода Б) используют пустой оператор ввода В) используют пустой оператор присваивания Г) не пишут в конце программы END.
Ответы (1)
Написать программу выбора дня недели, не используя оператора выбора case a of. Каждый день пронумерован от 1 до 7.
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)