Задать вопрос
9 февраля, 03:10

для заданного одномерного массива с компонентами вещественного типа написать программу решения задачи:

вычислить разность между наибольшим и наименьшим элементом.

+2
Ответы (2)
  1. 9 февраля, 05:47
    0
    program massiv;

    var

    a:array[1 ... 10] of integer;

    i, b, c : integer;

    begin

    writeln ('posledovatelno vedity elementi massiva (10 chisel) ') ;

    for i:=1 to 10 do

    readln (a[i]) ;

    b:=a[1];

    for i:=1 to 10 do

    begin

    if a[i]>b then

    b:=a[i];

    end;

    c:=a[1];

    for i:=1 to 10 do

    begin

    if a[i]
    c:=a[i];

    end;

    writeln ('raznost mesdu naibolshim i naimenshim elementom massiva = ', b-c) ;

    readln;

    end.

    p. s если нужны пояснения то в личку
  2. 9 февраля, 06:36
    0
    program fnued;

    uses crt;

    var a:=array [1 ... 1000] of integer;

    i, n, max, min, r:real;

    begin

    clrscr;

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ;

    min:=a[1];

    max:=a[1];

    for i:=1 to n do

    if a[i]>max then max:=a[i];

    for i:=1 to n do

    if a[i]
    r:=max-min;

    writeln (r) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «для заданного одномерного массива с компонентами вещественного типа написать программу решения задачи: вычислить разность между наибольшим ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
Создать программу получения и обработки одномерного массива - вектора: Вычислить значения 35 элементов одномерного целочисленного массива F в интервале (-6, 10) с использованием генератора случайных чисел
Ответы (1)