Задать вопрос
12 апреля, 02:41

С клавиатуры вводится последовательность из 13 целых чисел. Найти среднее арифметическое чисел, меньших 9

+1
Ответы (2)
  1. 12 апреля, 03:18
    0
    Паскаль.

    uses crt;

    var

    a, s, i, k:integer;

    begin

    s:=0; k:=0;

    for i:=1 to 13 do

    begin

    write ('Введите ', i,' число: ') ; read (a) ;

    if a<9 then

    begin

    s:=s+a; k:=k+1;

    end;

    end;

    write ('Среднее арифметическое чисел, меньших 9: ', s/k) ;

    end.
  2. 12 апреля, 04:41
    0
    var

    i : integer;

    val: integer;

    sum: integer;

    cnt: integer;

    begin

    sum:=0;

    cnt:=0;

    for i:=1 to 13 do

    begin

    readln (val) ;

    if (val<9) then

    begin

    cnt : = cnt + 1; 11

    sum : = sum + val;

    end;

    end;

    writeln (sum/cnt) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится последовательность из 13 целых чисел. Найти среднее арифметическое чисел, меньших 9 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)