Задать вопрос
29 июня, 07:52

Составить программы в Turbo Pascal. 1) Дано три точки A, B, C на числовой оси. Найти длинну отрезка AC и BC и их сумму. 2) Задано четыре целых числа a, b, c, d. Выяснить произведение этих чисел больше 300? 3) Дано целое число, если оно положительное, то прибавить к нему 1, а если отрицательное. то отнять от него 2. Вывести полученое число.

+4
Ответы (1)
  1. 29 июня, 11:36
    0
    первое

    program proga;

    uses crt;

    var

    a, b, c, x, y, z:integer;

    begin

    clrscr;

    writeln ('Введите значения точек') ;

    readln (a) ; readln (b) ; readln (c) ;

    x=b-c;

    y=c-b;

    z=x+y;

    readln;

    end.

    второе

    program proga;

    uses crt;

    var

    a, b, c, x, y, z:integer;

    begin

    clrscr;

    writeln ('Введите 4 числа') ;

    readln (a) ; readln (b) ; readln (c) ; readln (x) ; readln (y) ;

    z=a*b*c*y*x;

    if z>300 then

    writeln ('произведение этих чисел больше 300')

    else

    writeln ('произведение этих чисел меньше 300') ;

    readln;

    end.

    и соответственно третье

    program proga;

    uses crt;

    var

    a:integer;

    begin

    clrscr;

    writeln ('Введите число') ;

    readln (a) ;

    if a>0 then

    a=a+1;

    writeln (a)

    else

    if a<0 then

    a=a-2;

    writeln (a)

    else

    writeln ('вы ввели 0') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программы в Turbo Pascal. 1) Дано три точки A, B, C на числовой оси. Найти длинну отрезка AC и BC и их сумму. 2) Задано четыре ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Решить задачи: 1. Дано целое число. Если оно является положительным, то прибавить к нему 8, если нет, то не изменять. Вывести полученное число. 2. Дано целое чило.
Ответы (1)
дано число. если это число положительное, то вывести что оно положительное. в противном случае вывести, что оно отрицательное
Ответы (2)
Pascal ABC. Дано целое число. Если оно положительное, то удвоить его; если отрицательное, то вычесть из него 2; если нулевое, то заменить его на 10. Вывести полученное число.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)