Задать вопрос
24 марта, 20:29

1) Как, используя функцию random (X), можно получать числа в диапазонах: от 1 до 10, от - 10 до + 10, от 50 до 100?

2) какие значения может принимать целая переменная Y если в программе записано : Y : = 10 + ranodom (5) ?

3) составьте программу заполнения массива из 100 чисел случайными значениями из диапозона от - 20 до 20. подсчитайте в этом массиве колличество положительных и колличество отрицательных значения

+5
Ответы (2)
  1. 24 марта, 22:31
    0
    1)

    a:=1+Random (10) ;

    a:=-10+Random (20) ;

    a:=50+Random (50) ;

    2)

    10, 11, 12, 13, 14

    3)

    Program zadacha;

    Const n=100;

    Type massiv=Array[1 ... 1000] of Int64;

    Var a:massiv;

    i:Int64;

    Begin

    Randomize;

    For i:=1 to n do

    a[i]:=-20+Random (41) ;

    End.
  2. 24 марта, 22:51
    0
    1.

    random (10) + 1;

    random (21) - 10;

    random (100) + 50;

    2. y = [10; 14]

    3.

    var

    arr = array[1 ... 100] of real;

    rand : real;

    i : integer;

    p, n:integer;

    begin

    for i : = 1 to 100 do

    begin

    arr[i] : = random (41) - 20;

    i : = i+1;

    end;

    for i : = 1 to 100 do

    begin

    if arr[i] <0 then

    begin

    n : = n+1;

    end;

    if arr[i]>0 then

    begin

    p : = p+1;

    end;

    end;

    writeln ("positives: ", p) ;

    writeln ("negatives: ", n) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Как, используя функцию random (X), можно получать числа в диапазонах: от 1 до 10, от - 10 до + 10, от 50 до 100? 2) какие значения может ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите с заданиями по информатике 9 класс. 1) составьте программу заполнения массива а 1 ... 10 случайными целыми числами в диапозоне от N до M.
Ответы (1)