Задать вопрос
12 августа, 23:44

В паскале составить программу:

определить делимость на 3 для четырехзначного числа.

(думаю, что надо использовать св-во делимости числа: число будет делиться на 3, если сумма цифр этого числа будет делиться на три)

+5
Ответы (1)
  1. 13 августа, 00:55
    0
    var

    a: 1000 ... 9999;

    a1, a2, a3, a4: 0 ... 9; / / Цифры четырехзначного числа

    begin

    writeln ('Введите четырехзначное число') ;

    readln (a) ;

    a1: = a div 1000;

    a2: = (a mod 1000) div 100;

    a3: = (a mod 100) div 10;

    a4: = a mod 10;

    if (a1 + a2 + a3 + a4) mod 3 = 0 then writeln (a, ' делится на 3')

    else writeln (a, ' не делится на 3') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В паскале составить программу: определить делимость на 3 для четырехзначного числа. (думаю, что надо использовать св-во делимости числа: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Сегодня в школе на уроке математики проходят делимость. Чтобы продемонстрировать свойства делимости, учитель выписал на доске все целые числа от 1 до N в несколько групп, при этом если одно число делится на другое, то они обязательно оказались в
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Восьмиклассники Марина и Саша изучают тему "Делимость". Они уже знают, что число А делится без остатка на число Б, если число N можно представить в виде А = В * р, где р - некое целое число.
Ответы (1)