Задать вопрос
4 сентября, 11:49

дан масив из 10 целых положительных чисел, заполненный с клавиатуры. Найти максимальный и минимальный элемент в массиве и определить, на сколько максимальный элемент больше минимального.

+4
Ответы (1)
  1. 4 сентября, 15:49
    0
    const

    m = 10;

    var

    arr: array[1 ... m] of integer;

    i, j, k, r: integer;

    begin

    for i : = 1 to m do begin

    read (arr[i]) ;

    end;

    for i : = 1 to m-1 do

    for j : = 1 to m-i do

    if arr[j] > arr[j+1] then begin

    k : = arr[j];

    arr[j] : = arr[j+1];

    arr[j+1] : = k

    end;

    for i : = 1 to m do

    write (arr[i]:4) ;

    r:=arr[10]-arr[1];

    write (' ', r) ;

    writeln;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан масив из 10 целых положительных чисел, заполненный с клавиатуры. Найти максимальный и минимальный элемент в массиве и определить, на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык Паскаль. №1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, оканчивающиеся на цифру k. №2 Дан масив целых числ. Найти в этом массиве минимальный элмент m и максимальный M.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)
Дан масив из 12 целых чисел вывести исходный масив и получить новый элементы которого увеличены в 4 раза
Ответы (1)