Задать вопрос
14 апреля, 22:12

дана последовательность целых чисел а1 а2 ... ан. найти два минимальных элемента последовательности количество чисел вводится с клавиатуры

+1
Ответы (1)
  1. 14 апреля, 22:50
    0
    uses crt;

    var a:array[1 ... 100] of real;

    i, n, ind:integer; min, min2:real;

    begin

    clrscr;

    write ('n=') ; read (n) ;

    writeln ('massiv:') ;

    for i:=1 to n do

    read (a[i]) ;

    min:=a[1];

    min2:=a[1];

    for i:=1 to n do

    begin

    if a[i]
    begin

    min:=a[i];

    ind:=i;

    end;

    end;

    for i:=1 to n do

    begin

    if (iind) then if (a[i]
    end;

    write (min,' ', min2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дана последовательность целых чисел а1 а2 ... ан. найти два минимальных элемента последовательности количество чисел вводится с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)