Задать вопрос
10 января, 02:18

Вводится последовательность ненулевых чисел. 0-конец последовательности. Подсчитать, сколько в ней отрицательных чисел, и сумму положительных чисел.

+2
Ответы (1)
  1. 10 января, 04:43
    0
    var

    a, k, s:integer;

    begin

    repeat

    write (' = > ') ; readln (a) ;

    if a<0 then k:=k+1 else s:=s+a;

    until a=0;

    writeln ('Summa: ', s) ;

    writeln ('Kol-vo: ', k) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится последовательность ненулевых чисел. 0-конец последовательности. Подсчитать, сколько в ней отрицательных чисел, и сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Вводится последовательность целых ненулевых чисел, 0 - конец последовательности. Определить, сколько раз последовательность поменяет знак. Ограничения! Нельзя использовать условный оператор (If) и оператор выбора (Case).
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)