Задать вопрос
11 мая, 23:25

Составить блок схему и программу. Найти количество множителей для получения произведения всех натуральных чисел, чтобы произведение не превышало 200

+3
Ответы (1)
  1. 12 мая, 02:01
    0
    var Max, i, P:integer;

    Begin

    Max : = 200;

    i : = 1;

    P : = 1;

    while (P * (i+1) <=Max) do Begin

    i : = i + 1;

    P : = P * i;

    end;

    writeln (i, P) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить блок схему и программу. Найти количество множителей для получения произведения всех натуральных чисел, чтобы произведение не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Y={0, если х≤0 х, если 0
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно. 2. Составить блок - схему кипячения чайника. 3. Составить алгоритм сбора яблок в саду.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1. Вводится не менее восьми чисел. Конец ввода 0. Найти сумму первых пяти чисел и произведение последних пяти чисел. Составить блок-схему и программу к задаче. 2. Вводится текст. Конец ввода F4. Найти количество букв.
Ответы (1)