Задать вопрос
8 января, 16:19

Заполните два массива N [1 ... 15] и M [1 ... 15] случайными числами в диапозоне от - 15 до 20 ю Подсчитайте в каждом ммассиве количество положительных и отрицательных значений. Программа должна быть на Pascale, желательно на завтра.

+5
Ответы (1)
  1. 8 января, 19:19
    0
    Program pr;

    uses crt;

    Var N, M:array[1 ... 15] of integer;

    i, kNp, kMp, kNo, kMo:integer;

    Begin

    kNp:=0;

    kMp:=0;

    kNo:=0;

    kMo:=0;

    Writeln ('mas (N) ') ;

    for i:=1 to 15 do Begin N[i]:=random (36) - 15; Write (N[i],'; ') end;

    Writeln;

    Writeln ('mas (M) ') ;

    for i:=1 to 15 do Begin M[i]:=random (36) - 15; Write (M[i],'; ') end;

    for i:=1 to 15 do Begin

    if N[i]>=0 then kNp:=kNp+1

    else kNo:=kNo+1;

    if M[i]>=0 then kMp:=kMp+1

    else kMo:=kMo+1;

    end;

    Writeln;

    Writeln ('Кол-во положительных массива N=', kNp) ;

    Writeln ('Кол-во отрицательных массива N=', kNo) ;

    Writeln ('Кол-во положительных массива M=', kMp) ;

    Writeln ('Кол-во отрицательных массива M=', kMo) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполните два массива N [1 ... 15] и M [1 ... 15] случайными числами в диапозоне от - 15 до 20 ю Подсчитайте в каждом ммассиве количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Заполните массив случайными числами в диапазоне 20 ... 100 и подсчитайте отдельно число чётных и нечётных элементов (Программа Питон) 2. Заполните массив случайными числами в диапазоне 1000 ...
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите с заданиями по информатике 9 класс. 1) составьте программу заполнения массива а 1 ... 10 случайными целыми числами в диапозоне от N до M.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)