Задать вопрос
12 ноября, 02:38

Процедуры и функции.

паскаль

Даны 2 одномерных массива 10 целых чисел.

Найти сумму квадратов всех элементов массива для которых выполняется неравенство 0

+1
Ответы (1)
  1. 12 ноября, 04:24
    0
    program a;

    var i, n : integer;

    a, b, c : array [1 ... 10] of integer;

    begin

    for i:=1 to n do begin

    readln (a[i], b[i]) ;

    end;

    for i:=1 to 10 do begin

    if (a[i]>0) and (a[i]<10) then

    if (b[i]>0) and (b[i]<10) then

    c[i]:=a[i]*a[i]+b[i]*[b];

    endif;

    endif;

    end;

    for i:=1 to n do begin

    writeln ('C[', i,']=', c[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Процедуры и функции. паскаль Даны 2 одномерных массива 10 целых чисел. Найти сумму квадратов всех элементов массива для которых выполняется ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить преобразование массива так: все его элементы, большие девяти заменить числом девять, все его элементы, меньшие пяти заменить числом пять, а все
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)