Задать вопрос
27 октября, 17:57

1. Квадрат трехзначного числа оканчивается тремя цифрами, которые как раз и составляют это число. Найти такие числа (например, 625: 625^2=390 625).

2. Найти сумму целых положительных чисел, больших 20, меньших 100, кратных 3 и заканчивающихся на 2,4 или 8.

Решить в Паскале

+2
Ответы (1)
  1. 27 октября, 18:42
    0
    2)

    Program Numbers;

    Var

    i: integer;

    sum: integer;

    Begin

    sum : = 0;

    i : = 21;

    while i<=99 do

    begin

    if (i mod 10 = 2) or (i mod 10 = 4) or (i mod 10 = 8) then

    sum : = sum + i;

    i : = i + 3;

    end;

    WriteLn (sum) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Квадрат трехзначного числа оканчивается тремя цифрами, которые как раз и составляют это число. Найти такие числа (например, 625: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти количество целых положительных чисел, больших 100, меньших 500, кратных 12 и заканчивающихся на 4 или 6
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
Программы на паскале. 1. Из одномерного массива, состоящего из n целых элементов сформировать новый массив, состоящий только из положительных четных элементов больших 13 и меньших 23. 2.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)