Задать вопрос
31 октября, 21:01

Вася хочет узнать, какую оценку он получит в четверти по информатике. Учитель придерживается следующей системы: вычисляется среднее арифметическое всех оценок в журнале, и ставится ближайшая целая оценка, не превосходящая среднего арифметического. При этом если у школьника есть двойка, а следующая за ней оценка - не двойка, то двойка считается закрытой, и при вычислении среднего арифметического не учитывается. Входные данные Вводится десять натуральных чисел от 2 до 5 через пробел - оценки Васи. Выходные данные Выведите натуральное число (от 2 до 5) - его четвертную оценку.

входные данные:

2 5 2 5 2 5 2 5 2 5

2 2 2 2 2 2 2 2 2 5

5 5 5 5 5 5 5 5 5 2

выходные данные:

5

2

4

+3
Ответы (1)
  1. 31 октября, 21:53
    0
    решение в среде Паскаль:

    Var a:array[1 ... 10] of Integer; i, s, m: integer; f, t:real;

    begin

    s:=0;

    writeln ('write marks') ;

    For i:=1 to 10 do begin

    readln (a[i]) ;

    If i>1 then begin

    If a[i-1]=2 then begin

    If a[i]2 then begin s:=s-2; m:=m-1; end; end; end;

    s:=s+a[i];

    m:=m+1;

    end;

    f:=s/m;

    t:=Int (f) ;

    Writeln ('His or her mark is ', t:2:0) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вася хочет узнать, какую оценку он получит в четверти по информатике. Учитель придерживается следующей системы: вычисляется среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Вася за 1 четверть получил по информатике 20 оценок. Чтобы вычислить какую оценку он получит необходимо найти среднее арифметическое этих оценок. Напишите программу для нахождения среднего арифметического оценок.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)