Задать вопрос
25 января, 19:09

Составьте программу вычисления произведения тех значений элементов двумерного массива, которые меньше 15. Задача Паскаль

+1
Ответы (1)
  1. 25 января, 21:57
    0
    Условие элемент массива меньше 15 и не равен нулю потому, что иначе произведение почти всегда будет равно нулю. Если оно не нужно - удали фрагмент 'and (a[i, j]0) '

    Program n1;

    Uses CRT;

    Const n=10;

    Var a: array[1 ... n, 1 ... n] of integer;

    i, j: integer; p: longint;

    begin

    p:=1;

    For i:=1 to n do

    begin

    For j:=1 to n do

    begin

    a[i, j]:=random (50) ;

    if (a[i, j]<15) and (a[i, j]0) then p:=p*a[i, j];

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    writeln ('Proizvedenie = ', p) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления произведения тех значений элементов двумерного массива, которые меньше 15. Задача Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)