Задать вопрос
2 февраля, 12:51

Паскаль

Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1 ... 20] и выводит на экран элементы массива в нечетными значениями.

+4
Ответы (1)
  1. 2 февраля, 14:20
    0
    var

    a: array [1 ... 10] of integer; / / Инициализируем массив из 10 целых чисел

    i: integer;

    begin

    for i: = 1 to 10 do

    begin

    a[i]: = random (19) + 1; / / Заполняем массив случайными числами от 1 до 20

    if a[i] mod 2 = 1 then write (a[i], ' ') ; {Если очередной элемент массива нечетный, то он выводится}

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1 ... 20] и выводит на экран элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
1. Заполнить массив а [1 ... 14] случайными целыми числами в диапазоне от 1 до 18 и вывести на экран элементы массива с нечетными значениями, меньшими 10. 2. Заполнить массив а [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)