Задать вопрос
19 мая, 06:41

Даны целые числа, отличные от 0. Признаком завершения ввода будет число 0. Подсчитать, сколько было введено отрицательных трёхзначных чисел.

+1
Ответы (1)
  1. 19 мая, 08:39
    0
    var

    n, count, a: integer;

    begin

    repeat

    readln (a) ;

    if (a = - 999) then inc (count) ;

    until (a = 0) ;

    writeln ('Было введено отрицательных трехзначных чисел: ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целые числа, отличные от 0. Признаком завершения ввода будет число 0. Подсчитать, сколько было введено отрицательных трёхзначных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводятся целые числа. Окончание ввода - число ноль. Ноль используется только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру "5".
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
Собери из суждений правильное умозаключение. №1 все устройства ввода служат для ввода информации. №2 клавиатура служит для ввода информации. №3 клавиатура устройство ввода
Ответы (1)
Составьте схему алгоритма программы, которая будет осуществлять ввод чисел до тех пор, пока не будет введено число 17. Как только будет введено число 17, программа должна вывести количество введенных чисел
Ответы (1)