Задать вопрос
2 июля, 04:33

В Паскале вывести все числа, имеющие один делитель, кроме 1 и самого себя на диапазоне от A до B

+3
Ответы (1)
  1. 2 июля, 04:42
    0
    Var a, b, i, j, k:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    write ('b = ') ;

    readln (b) ;

    for i:=a to b do

    begin

    k:=0;

    for j:=2 to i div 2 do

    if i mod j=0 then k:=k+1;

    if k=1 then write (i,' ') ;

    end;

    end.

    Пример:

    a = 1

    b = 500

    4 9 25 49 121 169 289 361

    PS. Искомые числа - это квадраты простых чисел, поэтому можно и более эффективную программу написать.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале вывести все числа, имеющие один делитель, кроме 1 и самого себя на диапазоне от A до B ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. Входные данные: Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Основные виды сетевых топологий: шинная; кольцевая; линеиная; звездообразная. 1) все перечисленные, кроме "кольцевая" 2) все перечисленные, кроме "шинная" 3) все перечисленные 4) все перечисленные, кроме "звездообразная" 5) все перечисленные, кроме
Ответы (1)