Задать вопрос
10 сентября, 22:33

Программа: Ввести пятизначное число и найти сумму его цифр.

+3
Ответы (1)
  1. 11 сентября, 01:32
    0
    Первый вариант:

    Var A, S:longint;

    Begin

    S:=0;

    Write ('Введите пятизначное число: ') ; ReadLn (A) ;

    S:=S + (A div 10000) + (A div 1000) mod 10 + (A div 100) mod 10 + (A div 10) mod 10 + (A mod 10) ;

    Write ('S = ', S) ;

    End.

    Второй вариант:

    Var

    A:longint;

    S, i:integer;

    Begin

    S:=0;

    Write ('Введите пятизначное число: ') ; ReadLn (A) ;

    For i: = 1 to 5 do

    Begin

    S:=S+A mod 10;

    A:=A div 10;

    End;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа: Ввести пятизначное число и найти сумму его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)