Задать вопрос
17 марта, 00:29

Разработать программу которая принимает от пользователя два одномерных произвольных целочисленных массива а затем выводит на экран сумму и произведение всех элементов этих массивов

+2
Ответы (1)
  1. 17 марта, 04:27
    0
    C++

    #include

    using namespace std;

    int main ()

    {

    setlocale (LC_ALL, "Russian") ; / / Добавление русского языка

    int N;

    int * A, * B;

    int sub = 0, mult = 1;

    cout << "Введите размерность массивов: ";

    cin >> N;

    A = new int[N];

    B = new int[N];

    cout << "Инициализация массива A (введите " << N << " элементов) : ";

    for (int i = 0; i < N; i++)

    {

    cin >> A[i];

    }

    cout << "Инициализация массива B (введите " << N << " элементов) : ";

    for (int i = 0; i < N; i++)

    {

    cin >> B[i];

    }

    / / Подсчет суммы и произведения всех элементов массива

    for (int i = 0; i < N; i++)

    {

    sub = sub + A[i] + B[i];

    mult = mult*A[i] * B[i];

    }

    cout << "Сумма всех элементов массивов: " << sub << endl;

    cout << "Произведение всех элементов массивов: " << mult << endl;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать программу которая принимает от пользователя два одномерных произвольных целочисленных массива а затем выводит на экран сумму и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив отрицательные элементы начального массива. с применение подпрограмм и процедур желательно
Ответы (1)
Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить преобразование массива так: все его элементы, большие девяти заменить числом девять, все его элементы, меньшие пяти заменить числом пять, а все
Ответы (1)