Задать вопрос
21 августа, 21:02

Паскаль!

Задано слово длины 3n (n - натуральное число). Удалить в нем последнюю треть слова, а оставшиеся две трети перевернуть.

+4
Ответы (1)
  1. 21 августа, 23:16
    0
    var s, s1:string; n, i:integer;

    begin

    writeln ('Введите слово длиной 3n:') ;

    readln (s) ;

    n:=length (s) div 3;

    delete (s, 2*n+1, n) ;

    s1:='';

    for i:=1 to 2*n do s1:=s[i]+s1;

    writeln (s1) ;

    end.

    Пример:

    Введите слово длиной 3n:

    programma

    argorp
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Задано слово длины 3n (n - натуральное число). Удалить в нем последнюю треть слова, а оставшиеся две трети перевернуть. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу: 1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания 2. Задано четырехзначное число. Удалить из записи числа последнюю цифру.
Ответы (1)
Python! Дано слово из 12 букв. Поменять местами его трети следующим образом: а) первую треть слова разместить на месте третьей, вторую треть - на месте первой, третью треть - на месте второй;
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)