Задать вопрос
25 апреля, 20:07

В матрице хранится информация о зарплате n-участников за каждый месяц года. Определить среднюю зарплату за каждый месяц и в каком месяце средняя зарплата была самой высокой. Паскаль.

+1
Ответы (1)
  1. 25 апреля, 21:40
    0
    Const n=5; m=12;

    var

    a:array[1 ... n, 1 ... m] of integer;

    i, j, s, max, imax:integer;

    begin

    Randomize;

    writeln ('Зарплата за год:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (15000) + 10000;

    write (a[i, j]:6) ;

    end;

    writeln;

    end;

    writeln ('Средние зарплаты по месяцам:') ;

    max:=0;

    for j:=1 to m do

    begin

    s:=0;

    for i:=1 to n do s:=s+a[i, j];

    write (s/n:5:2,' ') ;

    if s>max then begin max:=s; imax:=j; end;

    end;

    writeln;

    writeln ('max = ', max/n:5:2,' месяц:', imax) ;

    end.

    Пример (для 4 месяцев, т. е. m=4) :

    Зарплата за год:

    12533 11176 15153 14194

    12649 22212 15546 17586

    23643 15664 15538 21740

    24382 10015 15816 24377

    11388 12739 18790 21034

    Средние зарплаты по месяцам:

    16919.00 14361.20 16168.60 19786.20

    max = 19786.20 месяц: 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В матрице хранится информация о зарплате n-участников за каждый месяц года. Определить среднюю зарплату за каждый месяц и в каком месяце ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу для подсчета и удержания подоходного налога для физических лиц. Ввести зарплату физического лица за февраль, вычислить значение подоходного на лога, вывести на экран сумму, которая подлежит выдаче работнику.
Ответы (1)
В двухмерном массиве хранится информация о зарплате 18 человек за каждый месяц года (за январь - в первом столбце, за февраль - во втором и т. д.). Определить общую зарплату, выплаченную в июне.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Какая информация называется достоверной? Выберите один ответ: Информация, которую можно представить графически Информация, которой удобно пользоваться Информация с минимумом фактов Информация, адекватно описывающая предметную область Информация,
Ответы (2)
Какая информация называется субъективной? Выберите один ответ: Информация, которая передаётся от одного субъекта другому Информация на дискете отдельного пользователя Информация, отражающая точку зрения отдельного пользователя Информация в бумажной
Ответы (2)