Задать вопрос
3 декабря, 17:19

Составить программу расчёта произведения элементов массива; найти в нём минимальный элемент и его номер

+5
Ответы (1)
  1. 3 декабря, 18:49
    0
    Program n1;

    const n=7

    var a: array [1 ... n] of integer;

    i, P, min, indMin: integer;

    begin

    P:=1;

    for i:=1 to n do readln (a[i]) ;

    for i:=1 to n do P:=P*a[i];

    min:=a[1];

    for i: = 2 to n do begin

    if a[i] < min then begin

    min:=a[i];

    indMin:=i;

    end;

    end;

    writeln (P) ;

    writeln (indMin,' ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу расчёта произведения элементов массива; найти в нём минимальный элемент и его номер ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)